package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[76]{1}[0-9]{8}$`)
var str = `789654123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}