$re = '/^[76]{1}[0-9]{8}$/m';
$str = '789654123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);