import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:31-(?:0?[13578]|1[02]))-|(?:(?:29|30)-(?:0?[1,3-9]|1[0-2])-))(?:(?:19|20)?\\d{2})|(?:29-0?2-(?:(?:(?:19|20)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))|(?:0?[1-9]|1\\d|2[0-8])(?:(?:0?[1-9])|(?:1[0-2]))-(?:(?:19|20)?\\d{2})$";
final String string = "31-07-2005";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}