import re
regex = re.compile(r"^(?:(?:31-(?:0?[13578]|1[02]))-|(?:(?:29|30)-(?:0?[1,3-9]|1[0-2])-))(?:(?:19|20)?\d{2})|(?:29-0?2-(?:(?:(?:19|20)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))|(?:0?[1-9]|1\d|2[0-8])(?:(?:0?[1-9])|(?:1[0-2]))-(?:(?:19|20)?\d{2})$")
test_str = "31-07-2005"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")