$re = '/\btest\b(?= *\()/m';
$str = 'String s = "This is a test() function"
String s2 = "This is a test () function"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);