re = /\btest\b(?= *\()/m
str = 'String s = "This is a test() function"
String s2 = "This is a test () function"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end