import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Renamed \\S+ to (\\S+)";
final String string = "2024-04-07 10:20:06,632 - INFO - Renamed clip_0.mp4 to 20240405_000001_S_002.mp4\n"
+ "2024-04-07 10:20:06,632 - INFO - Renamed clip_1.mp4 to 20240405_000002_S_005.mp4\n"
+ "2024-04-07 10:20:06,632 - INFO - Renamed clip_2.mp4 to 20240405_000003_S_069.mp4\n"
+ "2024-04-07 10:20:06,632 - INFO - Renamed clip_3.mp4 to 20240405_000004_S_040.mp4\n"
+ "2024-04-07 10:20:06,632 - INFO - Renamed clip_4.mp4 to 20240405_000005_S_012.mp4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}