const regex = /Renamed \S+ to (\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Renamed \\S+ to (\\S+)', 'gm')
const str = `2024-04-07 10:20:06,632 - INFO - Renamed clip_0.mp4 to 20240405_000001_S_002.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_1.mp4 to 20240405_000002_S_005.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_2.mp4 to 20240405_000003_S_069.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_3.mp4 to 20240405_000004_S_040.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_4.mp4 to 20240405_000005_S_012.mp4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}