$re = '/(?<!\d)\d{11}000\d{2}(?!\d)/m';
$str = '1234567890100012
abc1234567890100012abc
99991234567890100012
12345678901000129999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);