re = /(?<!\d)\d{11}000\d{2}(?!\d)/m
str = '1234567890100012
abc1234567890100012abc
99991234567890100012
12345678901000129999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end