using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-PR-UWYZ](?:(?:\d{1,2}|\d[A-HJ-KSTUW])|(?:[A-HK-Y]\d(?:\d|[A-Z])?)))\s?(\d[ABD-HJLNP-UW-Z]{2})\b";
string substitution = @"$1 $2";
string input = @"DD81UN
DD8 1UN
DN551PT
DN55 1PT
AN NAA M1 1AA
ANN NAA M60 1NW
AAN NAA CR2 6XH
AANN NAA DN55 1PT
ANA NAA W1A 1HQ
AANA NAA EC1A 1BB
DD8 2CA
DD8 2AA
DD8 2IA
DD8 2KA
DD8 2MA
DD8 2OA
DD8 2VA
DD8 2aa
AN
ANN
ANA
AAN
AANN
AANA
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}