const regex = /\b([A-PR-UWYZ](?:(?:\d{1,2}|\d[A-HJ-KSTUW])|(?:[A-HK-Y]\d(?:\d|[A-Z])?)))\s?(\d[ABD-HJLNP-UW-Z]{2})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-PR-UWYZ](?:(?:\\d{1,2}|\\d[A-HJ-KSTUW])|(?:[A-HK-Y]\\d(?:\\d|[A-Z])?)))\\s?(\\d[ABD-HJLNP-UW-Z]{2})\\b', 'g')
const str = `DD81UN
DD8 1UN
DN551PT
DN55 1PT
AN NAA M1 1AA
ANN NAA M60 1NW
AAN NAA CR2 6XH
AANN NAA DN55 1PT
ANA NAA W1A 1HQ
AANA NAA EC1A 1BB
DD8 2CA
DD8 2AA
DD8 2IA
DD8 2KA
DD8 2MA
DD8 2OA
DD8 2VA
DD8 2aa
AN
ANN
ANA
AAN
AANN
AANA
`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);