re = /(http(s)?:\/\/)?matrix\.to\/#\/(?P<room_id>[^\/]+)(\/(?P<event_id>[^\/?&#]+))?(?P<qs>([&?](via=[^&]+))*)?/m
str = 'https://matrix.to/#/!PFcniQbnBEDpZRjAFF:matrix.org/$fJ3mYO2y09VdV5INemzXirpeuBLsKQGquiVA8wJIRmU?via=matrix.org&via=nexy7574.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end