use strict;
my $str = 'word dark king glow we end hello bye low wing
word Dark King Glow We End hello bye LoW wing
A a A b B C c C C';
my $regex = qr/(?is)[a-z]*([a-z])(?= (\1)[a-z]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}