$re = '/(?is)[a-z]*([a-z])(?= (\1)[a-z]*)/';
$str = 'word dark king glow we end hello bye low wing
word Dark King Glow We End hello bye LoW wing
A a A b B C c C C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);