$re = '/\b(\(?0?\d{2}\)?)?\s?9[\s\-]?\d{4}[\s\-]?\d{4}\b/m';
$str = '---> DEVE ENCONTRAR:
11991234567
011991234567
119111111111 <- Tem certeza que deve encontrar? tem 11 (DDD) e depois tem 10 dígitos
11 99123 4567
011 99123 4567
11 9 9123 4567
011 9 9123 4567
---> DEVE ENCONTRAR (EXEMPLOS DA PERGUNTA + ALGUMAS EXTENSÕES):
993345987
9 93345987
(21)932324343
(021)932324343
(21)9 3232 4343
(021)9 3232 4343
(21) 9 3232 4343
(021) 9 3232 4343
NÃO DEVE ENCONTRAR:
11 99123 45671
111 99123 4567
011 99123 45678
811 99123 45678
a9999999999999999999989999123
118111111111
123456789123456789
33933333333333333333
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);