re = /[a-c]/m
str = 'ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end