import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]%";
final String string = "12%\n"
+ "ab\n"
+ "abc\n"
+ "abcc\n"
+ "abccc\n"
+ "abcccc\n"
+ "abccccc\n"
+ "abcccccc\n"
+ "abcbcbcbc\n"
+ "abcbcbcbcbcbc\n"
+ "- _ { } @ \n"
+ "3%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}