re = /[0-9]%/m
str = '12%
ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc
- _ { } @
3%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end