package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z]`)
var str = `12%
ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc
- _ { } @
3%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}