$re = '/[^a-zA-Z]/m';
$str = '12%
ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc
- _ { } @
3%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);