package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d]{9}`)
var str = `111111111
222222222
333333333
444444444
077546997`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}