use strict;
my $str = 'ext:tech.IBMMQ_Java.Queue.Depth: { Queue=ATDX01M2.CSV.NOTIFICATIONS_FROM_SYSTEM, dt.entity.custom_device=CUSTOM_DEVICE-C43C30B0FE89F372 }
ext:tech.IBMMQ_Java.Queue.Depth: { Queue=ATDX44M2.CDS.ABC.REQUESTQ, dt.entity.custom_device=CUSTOM_DEVICE-C4D1C6E4782764FB }
ext:tech.IBMMQ_Java.Queue.Depth: { Queue=ATDX01M1.CSV.ESB.ABC.XYZ_MESSAGES, dt.entity.custom_device=CUSTOM_DEVICE-57183614D438F39E }';
my $regex = qr`.*Queue=([^\,].*),.*`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}