$re = '`.*Queue=([^\,].*),.*`m';
$str = 'ext:tech.IBMMQ_Java.Queue.Depth: { Queue=ATDX01M2.CSV.NOTIFICATIONS_FROM_SYSTEM, dt.entity.custom_device=CUSTOM_DEVICE-C43C30B0FE89F372 }
ext:tech.IBMMQ_Java.Queue.Depth: { Queue=ATDX44M2.CDS.ABC.REQUESTQ, dt.entity.custom_device=CUSTOM_DEVICE-C4D1C6E4782764FB }
ext:tech.IBMMQ_Java.Queue.Depth: { Queue=ATDX01M1.CSV.ESB.ABC.XYZ_MESSAGES, dt.entity.custom_device=CUSTOM_DEVICE-57183614D438F39E }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);