#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)c0"><span>(?<Ref>.+?)<\/.+nowrap;">(?<PartName>.+?)<\/.+itemnum(?:new)?">(?<ItemNumber>.+?)<\/.+dbl">(?<Price>.+?)<\/.+input" value="(?<Quantity>.+?)""
Local $sString = "<div class="partlistrow">" & @CRLF & _
" <form action="/cart/addoempart" data-name="Valve, Intake" data-qoh="0" data-sku="5NL-12111-00-00" id="add_1_5NL-12111-00-00" method="post">" & @CRLF & _
" <input type="hidden" id="manf_1" name="manf" value="YAM" />" & @CRLF & _
" <input type="hidden" id="assembly_1" name="assembly" value="500449cff8700209bc790600" />" & @CRLF & _
" <input type="hidden" id="sku_1" name="sku" value="5NL-12111-00-00" />" & @CRLF & _
" <div class="c0"><span>1</span></div>" & @CRLF & _
" <div class="c1">" & @CRLF & _
" <div class="c1a" style="width:100%;display:table;table-layout:fixed;">" & @CRLF & _
" <span style="white-space: nowrap;">Valve, Intake</span>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="clear"></div>" & @CRLF & _
" <div class="c1b">" & @CRLF & _
" " & @CRLF & _
" <a href="/oemparts/p/yamaha/5nl-12111-00-00/valve-intake"><span class="itemnumstrike">5NL-12111-00-00</span></a> <a href="/oemparts/p/yamaha/5nl-12111-30-00/valve-intake"><span class="itemnumnew">5NL-12111-30-00</span></a>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" <div class="clear"></div>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="c2"><span class="dbl">$116.99</span></div> " & @CRLF & _
" <div class="c3"><input type="text" id="qty_1" name="qty" class="input_1 center required qtyinput" value="1" /></div>" & @CRLF & _
" <div class="c4"><input type="submit" id="addtocart_1_5NL-12111-00-00" class="ui ui-icon-smadd btnpartadd" value="Add" /></div>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <div class="clear"></div>" & @CRLF & _
" </form>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")