import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)c0\"><span>(?<Ref>.+?)<\\/.+nowrap;\">(?<PartName>.+?)<\\/.+itemnum(?:new)?\">(?<ItemNumber>.+?)<\\/.+dbl\">(?<Price>.+?)<\\/.+input\" value=\"(?<Quantity>.+?)\"";
final String string = "<div class=\"partlistrow\">\n"
+ " <form action=\"/cart/addoempart\" data-name=\"Valve, Intake\" data-qoh=\"0\" data-sku=\"5NL-12111-00-00\" id=\"add_1_5NL-12111-00-00\" method=\"post\">\n"
+ " <input type=\"hidden\" id=\"manf_1\" name=\"manf\" value=\"YAM\" />\n"
+ " <input type=\"hidden\" id=\"assembly_1\" name=\"assembly\" value=\"500449cff8700209bc790600\" />\n"
+ " <input type=\"hidden\" id=\"sku_1\" name=\"sku\" value=\"5NL-12111-00-00\" />\n"
+ " <div class=\"c0\"><span>1</span></div>\n"
+ " <div class=\"c1\">\n"
+ " <div class=\"c1a\" style=\"width:100%;display:table;table-layout:fixed;\">\n"
+ " <span style=\"white-space: nowrap;\">Valve, Intake</span>\n"
+ " </div>\n"
+ " <div class=\"clear\"></div>\n"
+ " <div class=\"c1b\">\n"
+ " \n"
+ " <a href=\"/oemparts/p/yamaha/5nl-12111-00-00/valve-intake\"><span class=\"itemnumstrike\">5NL-12111-00-00</span></a> <a href=\"/oemparts/p/yamaha/5nl-12111-30-00/valve-intake\"><span class=\"itemnumnew\">5NL-12111-30-00</span></a>\n"
+ " \n"
+ " </div>\n"
+ " <div class=\"clear\"></div>\n"
+ " \n"
+ " </div>\n"
+ " \n"
+ " <div class=\"c2\"><span class=\"dbl\">$116.99</span></div> \n"
+ " <div class=\"c3\"><input type=\"text\" id=\"qty_1\" name=\"qty\" class=\"input_1 center required qtyinput\" value=\"1\" /></div>\n"
+ " <div class=\"c4\"><input type=\"submit\" id=\"addtocart_1_5NL-12111-00-00\" class=\"ui ui-icon-smadd btnpartadd\" value=\"Add\" /></div>\n"
+ " \n"
+ " \n"
+ " <div class=\"clear\"></div>\n"
+ " </form>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}