package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^:]+:([a-z]+)-([a-z]+)([\d.]+)$`)
var str = `dn1:pts-sc1.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}