$re = '/^[^:]+:([a-z]+)-([a-z]+)([\d.]+)$/';
$str = 'dn1:pts-sc1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);