package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.{1,2}$|[^6].{2}|.[^6].|.{2}[^6]).*`)
var str = `666`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}