$re = '/^(.{1,2}$|[^6].{2}|.[^6].|.{2}[^6]).*/';
$str = '666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);