$re = '/((?<!^)([A-Z][a-z]|(?<=[a-z])[A-Z]))/m';
$str = 'IMACSuperSeriousLabelDCN
CSVFilesAreCoolButTXT';
$subst = " $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;