$re = '/(?<=\d\.)\s+(?=\d)/m';
$str = 'It costs 2. 5. That is a lot.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;