import re
regex = re.compile(r"(?<=\d\.)\s+(?=\d)", flags=re.MULTILINE)
test_str = "It costs 2. 5. That is a lot."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)