re = /</
str = '[a href="https://www.example.com/page"]Example page[/a] is a [strong]valid[/strong] tag.
[em class="something"] is also allowed[/em]
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type="text/javascript">alert(\'xss\'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<'
subst = '<'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result