// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<").unwrap();
let string = "[a href=\"https://www.example.com/page\"]Example page[/a] is a [strong]valid[/strong] tag.
[em class=\"something\"] is also allowed[/em]
But <param> or <argument> should be escaped.
This also: <br/> <
br /> <script type=\"text/javascript\">alert('xss'></script>
Turn left <- or turn right ->
Also, accept this => or a smiley >.<";
let substitution = "<";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}