package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:#|!).*?$`)
var str = `hui # 123123
hui
hui !12312`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}