$re = '/(?:#|!).*?$/m';
$str = 'hui # 123123
hui
hui !12312';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);