$re = '/\\\\/';
$str = 'What if Mozilla changed their wordmark from moz://a to moz:\\\\a?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);