re = /\\/
str = 'What if Mozilla changed their wordmark from moz://a to moz:\\\\a?'
# Print the match result
str.match(re) do |match|
puts match.to_s
end