using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\b(username.*privilege) (?![01]\b)[0-9]+ (password [0-9]+).*";
string input = @"username myuser privilege 15 password 7 5345345345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}