$re = '/.*\b(username.*privilege) (?![01]\b)[0-9]+ (password [0-9]+).*/m';
$str = 'username myuser privilege 15 password 7 5345345345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);