$re = '/(?s)([A-G][1-3])((?:(?![A-G][1-3]).)*)/';
$str = 'A1 ACBFEKJRQ0Z+-F2.,12STLMGHDF19)(D2!?56WXPC1IONVU43\\"\\\'E1Y87><A3-=.,\\\'\\"!?><()@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);