re = /(?s)([A-G][1-3])((?:(?![A-G][1-3]).)*)/
str = 'A1 ACBFEKJRQ0Z+-F2.,12STLMGHDF19)(D2!?56WXPC1IONVU43\\"\\\'E1Y87><A3-=.,\\\'\\"!?><()@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end