import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:\\d{11}|(?=\\d{0,5}[A-Z])[A-Z0-9]{6})(?:[\\s\\.]|$)";
final String string = "12345678901\n"
+ "123456\n"
+ "123F56\n"
+ "A12345\n"
+ "123456.4\n"
+ "123456.B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}