const regex = /\b(?:\d{11}|(?=\d{0,5}[A-Z])[A-Z0-9]{6})(?:[\s\.]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:\\d{11}|(?=\\d{0,5}[A-Z])[A-Z0-9]{6})(?:[\\s\\.]|$)', 'gm')
const str = `12345678901
123456
123F56
A12345
123456.4
123456.B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}