const regex = /(\/\*[^*]*[^/]*\*\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\*[^*]*[^\/]*\\*\\\/)', 'g')
const str = `This is/ some code /* these are some comments
=412414515/ * somechars / ][;';'] */*/
Some more code
/* and some more unreadable comments a[dpas[;[];135///]]
d0gewt0qkgekg;l''\\////
*/ god i hate regex /* asda*asd
\\asd*sd */`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}