re = /(\/\*[^*]*[^\/]*\*\/)/
str = 'This is/ some code /* these are some comments
=412414515/ * somechars / ][;\';\'] */*/
Some more code
/* and some more unreadable comments a[dpas[;[];135///]]
d0gewt0qkgekg;l\'\'\\////
*/ god i hate regex /* asda*asd
\\asd*sd */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end