$re = '/^[a-z]+(?:[-\'][a-z]+)*\.[a-z]+(?:[-\'][a-z0-9]+)*$/i';
$str = 'shaun.o\'brien-Thompson
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);