re = /^[a-z]+(?:[-'][a-z]+)*\.[a-z]+(?:[-'][a-z0-9]+)*$/i
str = 'shaun.o\'brien-Thompson
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end