import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)[\\w\\-.]+(?=(\\?|(\\s*)$|(\\/)$))";
final String string = "https://www.tokopedia.com/laris88/tempat-bumbu-dapur-4-sekat-joyfeel-1047-seasoning-storage-merah-muda\n"
+ "https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali?whid=0\n"
+ "https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali\n"
+ "https://gql.tokopedia.com/tokopedia.com/\n"
+ "https://gql.tokopedia.com/ceriasmart/\n"
+ "https://gql.tokopedia.com/22ceria.-smart/\n\n"
+ "tokopedia\\.com/([^/]+[\\w])\n\n\n\n"
+ "todo\n"
+ "i want grab only \"gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali\" without end character '?'\n\n"
+ "tokopedia\\.com/[^/]*[\\w\\/](.*)|[?!\\?]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}